Announcement

Collapse
No announcement yet.

V2 acting like new filter is plugged

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • V2 acting like new filter is plugged

    Wondering if any of you V2 users have run into this. I finally figured out what the problem is but mabe should put thisout there.

    Filter is changed. Starts and runs normally(Switches to oil automaticaly).

    When I floor it overtaking another vehicle, the system kicks off. I stop the vehicle, and I'm still full of oil, new filter, but cant purge the filter.


    After blowing out the lines, and rechecking for air leaks I kind of found out what I think the problem is.

    1) Oil filter heater is always on. Even when the truck is off. Battery voltage is low. I disconnected the heater. Does anyone else with the V2 have this problem?

    2) Battery has just enough juice to start the truck. I run my Headlights on all the time because the Volcano haze is pretty bad and oncomming cars have a hard time seeing me.

    3) FASS pump can't pump to pressure because of low voltage. I assume oil psi drops, and system kicks back to diesel.


    Once I put the charger on, everything is all good.


    I hope this helps other V2 users.
    2001 Excursion, V3, TS Chip, Walker BTM.
    2002 F350 Crew, V2, DP Tuner, Walker BTM.

  • #2
    Originally posted by Hawaiian Diesel View Post
    Wondering if any of you V2 users have run into this. I finally figured out what the problem is but mabe should put thisout there.

    Filter is changed. Starts and runs normally(Switches to oil automaticaly).

    When I floor it overtaking another vehicle, the system kicks off. I stop the vehicle, and I'm still full of oil, new filter, but cant purge the filter.


    After blowing out the lines, and rechecking for air leaks I kind of found out what I think the problem is.

    1) Oil filter heater is always on. Even when the truck is off. Battery voltage is low. I disconnected the heater. Does anyone else with the V2 have this problem?

    2) Battery has just enough juice to start the truck. I run my Headlights on all the time because the Volcano haze is pretty bad and oncomming cars have a hard time seeing me.

    3) FASS pump can't pump to pressure because of low voltage. I assume oil psi drops, and system kicks back to diesel.


    Once I put the charger on, everything is all good.


    I hope this helps other V2 users.

    Don't know anything about the V2 but am surprised that the filter heater is on even when the truck is off. Is it supposed to be that way? Can it be rewired to go off when the truck shuts down? - Patrick

    Comment


    • #3
      Sounds like you have the power wired wrong. The 12v heater should not be on untill you switch the V2 on IIRC

      Comment

      Working...
      X