Announcement

Collapse
No announcement yet.

First problem with my V3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • First problem with my V3

    Hey Guys and Gals. Haven't been on the site for quite awhile and Life has been good.
    Yesterday as I was driving, I started hearing a noise from my truck. At a red light, I rolled down my window and it was pretty loud. the noise was coming from my module.
    When I got home, I shut down the engine, turned the key on and then put the switch in manual to have the system come on.
    The pump is making a sotra grinding sound. Like a a/c compressor when it is bypasing freon. I noticed a couple of days ago that my diesel and veg gague have been dropping pretty much evenly. Meaning that I had used half a tank of veg and almost half a tank of diesel. I knew that something wasn't quite right. I even installed a new filter to see if it had any effect. No effect.
    So, I think my pump is going out.
    anyone else have pump problems???
    Elvia the HandyMan
    2000 F350 7.3 XL Dually utility/service truck
    V3 March 2008

  • #2
    Wow, a pump going out already is unusual. I have not heard of anyone having a failed pump so soon. How many miles have you got on it?

    Comment


    • #3
      Hey Clay
      I have about 15,000 miles on it now. I installed the kit on March 15, 2008.
      So it is almost a year old now
      Elvia the HandyMan
      2000 F350 7.3 XL Dually utility/service truck
      V3 March 2008

      Comment


      • #4
        Been there done that

        Elvia our systems were installed within 3 days of each other and my pump failed in may 08,with 7,000 miles on it.I believe we had a "bad" batch of fass pumps(My cousin had a FASS pump fail in a different application (DRAG TRUCK duel fass set-up),that pump was shipped about the same time thru FASS and seemed to have same "inerds" when in disected..........NOT a DFA flaw,definately machining from FASS on the seal in housing.On mine WVO got into the electric"BRUSHES" and it made a "marbles in the blender sound".Have no fear it isn't the first to go just not common place...........PM with Q's on mine...........greasy
        2000 7.3X V3 So much fun,so little time,Support small Oil,burn WVO,Free and greasy down the road I go!!!!!!!!!!completely self sufficient and proud of it. (Wood furnace.....X.......solar pontoon....solarsheat twins this summer.....I don't Know much.......I'm just a hillbilly with too many guns..............

        Comment


        • #5
          Originally posted by Elvia View Post
          Hey Guys and Gals. Haven't been on the site for quite awhile and Life has been good.
          Yesterday as I was driving, I started hearing a noise from my truck. At a red light, I rolled down my window and it was pretty loud. the noise was coming from my module.
          When I got home, I shut down the engine, turned the key on and then put the switch in manual to have the system come on.
          The pump is making a sotra grinding sound. Like a a/c compressor when it is bypasing freon. I noticed a couple of days ago that my diesel and veg gague have been dropping pretty much evenly. Meaning that I had used half a tank of veg and almost half a tank of diesel. I knew that something wasn't quite right. I even installed a new filter to see if it had any effect. No effect.
          So, I think my pump is going out.
          anyone else have pump problems???
          Awe man thats a bummer to bad that those guys from DFA won't talk to you unless you wallets out!!! :chuckles::chuckles::chuckles: Just kidding, give me a call Elvia!

          Comment

          Working...
          X