Announcement

Collapse
No announcement yet.

not oil related

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • not oil related

    Hi guys does any one have an idea why the cruise control would just suddenly quit working? Worked fine a week ago and then this weekend nothing. Just looking for a place to start and will have to take it in if we can not find it can not stand the thought of a drive from South Dakota to New York with out it.

    Oh and Clay for those of us (meaning me) not smart enough to have the Powerstroke forum bookmarked would you please give us the link again.

    Thanks Tanya

  • #2
    Interesting, Tanya, My cruise control stopped working also?? When we evacuated for Gustav it didn't work. Most of my (all) driving is local in town so, I hadn't noticed before.
    Elvia the HandyMan
    2000 F350 7.3 XL Dually utility/service truck
    V3 March 2008

    Comment


    • #3
      Clutch switch on a 6spd... (Will it start w/o pushing clutch?)

      There's more ya need to know about PSD clutch pedal, etc - lemme know!

      Run the 'switches' (or whateva its called ) test w/ Autoenginuity or similar (dealer-like) code scanner.

      There are like 240 sensors, etc on a PSD.
      Last edited by skyskijason; 09-15-2008, 05:19 PM.
      2001 F350 XLT 4x4, dually flatbed. 6637 air filter, single-shot injectors, straight-piped, BTS tunes, 200 gal main VO tank - 180k greasy miles
      2000 Excursion Limited 4x4. V3, AIS intake, BTS trans & tunes - 120k VO miles
      veggiegarage.com authorized installer

      RIP X & Toyhauler - you served us well.

      Comment


      • #4
        ford just had a recall on cruise control switches,check the year
        2000 7.3X V3 So much fun,so little time,Support small Oil,burn WVO,Free and greasy down the road I go!!!!!!!!!!completely self sufficient and proud of it. (Wood furnace.....X.......solar pontoon....solarsheat twins this summer.....I don't Know much.......I'm just a hillbilly with too many guns..............

        Comment


        • #5
          Hi again guess I should have given a little more info. It is a 2001 automatic transmission.

          GreasyX I did a check on the vin number and there are supposedly no outstanding recalls but one of the sites said some of that year had cruise control problems.

          Hubby checked fuses tonight and it looks fine so I guess it will have to go into the shop. Thanks for the help.

          Elvia it sure is a pain on open road to have to keep my foot on that peddle it wants to make the truck go way too fast.

          Tanya

          Comment


          • #6
            Originally posted by tanya View Post
            Oh and Clay for those of us (meaning me) not smart enough to have the Powerstroke forum bookmarked would you please give us the link again.

            Thanks Tanya
            You mean this?
            <<<Link>>>

            Comment


            • #7
              Yes Clay thank you very much thought I could search there then could not find that site.

              Tanya

              Comment


              • #8
                Culprit found. It was a bad break pressure switch. They replaced it and it is working fine now. Elvia it was under the hood some where if that helps any.

                Tanya

                Comment


                • #9
                  LOL Tanya thats too funny, "under the hood somewhere"
                  Elvia the HandyMan
                  2000 F350 7.3 XL Dually utility/service truck
                  V3 March 2008

                  Comment


                  • #10
                    Well it wasn't under the dash or in the steering collum and my spelling is no better than my directions. Tanya

                    Comment

                    Working...
                    X