Announcement

Collapse
No announcement yet.

Beginners Question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Beginners Question

    I have the V3 installed on a 2003 6.0L with a 60gal tank.The question is: on the way home from hunting this afternoon the green light on the toggle switch came on. Why? I have not started running vegi oil in the truck yet. I thought that light was only for the filter being clogged? The truck was not running bad. When I got home I noticed that it was on when the truck was running. Upon further investigation I noticed that when you turn the key on and the diesel pump was running the light was on. When the pump went off the light also went off.

    Further history: the system has been installed for 3 to 4 months with no vegi oil ran thru the system. I was going to start running vegi oil next week. As a matter of fact I am filtering my first batch of oil now.

    Please help.

    PS Dino Fuel Alt. where are the wiring diagrams?

    thanks
    chris
    Last edited by stymous222; 11-27-2008, 06:24 PM.

  • #2
    Originally posted by stymous222 View Post
    I have the V3 installed on a 2003 6.0L with a 60gal tank.The question is: on the way home from hunting this afternoon the green light on the toggle switch came on. Why? I have not started running vegi oil in the truck yet. I thought that light was only for the filter being clogged? The truck was not running bad. When I got home I noticed that it was on when the truck was running. Upon further investigation I noticed that when you turn the key on and the diesel pump was running the light was on. When the pump went off the light also went off.

    Further history: the system has been installed for 3 to 4 months with no vegi oil ran thru the system. I was going to start running vegi oil next week. As a matter of fact I am filtering my first batch of oil now.

    Please help.

    PS Dino Fuel Alt. where are the wiring diagrams?

    thanks
    chris
    Chris,
    Any chance the rocker switch could have accidentally gotten pushed to the manual on position? Can you verify that the left rocker switch is in the middle position (veg system off)? Also, when you say that the light went off when the diesel pump went off, are you saying that all of this happened when you turned the ignition key off? - Patrick

    Comment


    • #3
      Chris,
      Forgot to ask in my first post if the green light is coming on when the truck is cold or up to operating temperature. Make sure the rocker switch is not in the automatic or manual position (should be in the middle or "off" position). - Patrick

      Comment


      • #4
        light problems

        yes, i can verify that the switch is in the center possition (vegi sys off). this only happens with the key on, and what i mean by the light being on when the diesel pump is running, is just that. when you turn my key on the diesel pump turns on to prime the line for starting. if you do not crank the truck, the diesel pump will turn off when it gets pressurized. that is when the light will turn off, when the diesel pump is off, but if you were to crank the truck the diesel pump will start up and the green light will come back on. this started while the truck was running. and the light just came on. remember i have not ran any vegi oil thru the system yet. there is no way the filter could be clogged. i will check the pressure switch on monday. i read on another post that they were having problems with the pressure switch.

        if you or anyone else has any other ideas, please let me know.

        thanks again
        chris

        Comment


        • #5
          Originally posted by stymous222 View Post
          yes, i can verify that the switch is in the center possition (vegi sys off). this only happens with the key on, and what i mean by the light being on when the diesel pump is running, is just that. when you turn my key on the diesel pump turns on to prime the line for starting. if you do not crank the truck, the diesel pump will turn off when it gets pressurized. that is when the light will turn off, when the diesel pump is off, but if you were to crank the truck the diesel pump will start up and the green light will come back on. this started while the truck was running. and the light just came on. remember i have not ran any vegi oil thru the system yet. there is no way the filter could be clogged. i will check the pressure switch on monday. i read on another post that they were having problems with the pressure switch.

          if you or anyone else has any other ideas, please let me know.

          thanks again
          chris
          Chris,
          If you were to have your V3 up and running on automatic with veg in the tank and the system warmed up, the green light would be on indicating the system is pressurized and supplying veg. If you experience a plugged filter, the green light actually goes out.

          Not sure how that green light can be on with the system switched off. Any chance you could have a short in wiring somewhere? - Patrick

          Comment


          • #6
            something new

            here is something new. i thought that i would pull the power wire off the battery to see if the light would go off. pull the wire and the light stayed on. so i drove the truck and nothing, the light stayed on. UNTIL, i switched the left toggle switch down and at that time the light went off. then no matter what possition i had the switch in the light never came back on (mind you this is still with the battery wire disconnected). so when i reached where i was going i pluged the battery wire back up. the light did not come back on. so i started the truck and the light still did not come on (which is normal with the switch in the off possition). the only time i came on was when the switch was pushed down, which i think was manual. so now the light seems to be working normal. do you think i could have had a sticking pressure switch? and is the pressure switch the only thing that effects that light in normal opperation?

            Also, if that light stays on the entire time that the V3 is running what does everyone do about the brightness of the light? that thing almost blinded me when it came on.

            thanks
            chris

            Comment


            • #7
              Originally posted by stymous222 View Post
              do you think i could have had a sticking pressure switch? and is the pressure switch the only thing that effects that light in normal opperation?

              Also, if that light stays on the entire time that the V3 is running what does everyone do about the brightness of the light? that thing almost blinded me when it came on.

              thanks
              chris
              It is my understanding that pressure and temp have to be up to spec for the system to turn on.

              Yes, that light stays on the entire time. I sit where the steering wheel blocks most of the light and I just see ambient light. Guys are putting dark/black nail polish on them to dim them, but I like it bright, makes it easier to see in the daylight.

              Get some oil in that beast!!!
              Vegistrokin since 08/23/08

              Comment


              • #8
                oil it is.

                yes, i will be getting oil in the beast this week. that is if the light will stay off on the way home in the morning. i will be needing it to run the 50 plus miles to duck camp this weekend.

                i will be putting something on the light to dim it during the night operation. maybe i will only paint the top half or just put a dot of something in the center, just something to dim it just a little.

                thanks
                chris

                Comment


                • #9
                  Chris, is it still working properly or is it giving you more trouble?

                  My first thought was wiring. Did you double check your connections?
                  Greasin & Grinin
                  Vegi oil powered since Aug 08
                  2006 F-250 PSD - CC, Lariat, 4X4 - Vegistroke converted 1/27/13!!
                  2008 F-250 PSD - CC, Lariat, 4X4 - Sold
                  2005 F-250 PSD - CC, Lariat, 4X4 - Sold

                  Comment


                  • #10
                    well I can tell you from exp with mine.... I drove for a while w/out my veg tank since it was on order.

                    My light came on and I was like wtf?

                    As it turned out that was the beginning of my pressure switch troubles.

                    You should do some ohm meter checks on it. One side should be open and one side should be a short.

                    It's posted in here somewhere.. Alas get on the phone with DFA and they will confirm/get you a new press switch.

                    my new one has been perfect.

                    PS- how long ago did you purchase this V3?
                    2005 6.0l X
                    V3 running 8/6/08
                    40gal frame mounted tank

                    Live by the grease, die by the grease

                    Comment


                    • #11
                      light troubles

                      well, on the way home this morning the light stayed off. so, i filtered me some oil (about 20gals) and stuck it in the tank. worked very good on the way to work. the only thing is the radio is staying on when the truck turns off. from what i hear that is somewhat normal. you just have to wait until the truck stops running and open the door to turn the radio off.

                      wilson: the system has been installed completly for about 6 mths. and the v3 module for about 7-8 mths. and purchased it almost a year ago. i am going to check the switch in the morning when i get home.

                      marv: i did check the wiring connections first thing. hey checked good. but you could almost rule out wiring shorted when i disconnected the power wire and toggled the switch and the light went out. my guess is a stuck pressure switch, but the ohm meter will tell in the morning.

                      over all i am happy that the system is working and don't know why i did not do this earlier. :cheers:

                      thanks
                      chris

                      Comment


                      • #12
                        Originally posted by stymous222 View Post
                        from what i hear that is somewhat normal. you just have to wait until the truck stops running and open the door to turn the radio off.

                        wilson: the system has been installed completly for about 6 mths. and the v3 module for about 7-8 mths. and purchased it almost a year ago. i am going to check the switch in the morning when i get home.

                        thanks
                        chris
                        yeah my radio stays on too.

                        sounds like your switch was working then..
                        2005 6.0l X
                        V3 running 8/6/08
                        40gal frame mounted tank

                        Live by the grease, die by the grease

                        Comment


                        • #13
                          does anyone know of a fix for the radio staying on?

                          chris

                          Comment


                          • #14
                            Originally posted by stymous222 View Post
                            does anyone know of a fix for the radio staying on?

                            chris
                            Turn off the radio before you shut down.

                            Comment


                            • #15
                              The radio stayes on the same way it will if you park and take the keys out of the ignition...radio continues to play for like 5 minutes or something or untill you open the door....whichever occures first. Its not going to run down the battery but if you don't want it on, turn it off.
                              Last edited by Clay; 11-26-2008, 08:02 AM.

                              Comment

                              Working...
                              X